Welcome, Guest. Please Login or Register
Decware Audio Forums
04/01/20 at 17:43:07†


       


Pages: 1
Send Topic Print
Trouble in Paradise (Read 875 times)
Melvin
Seasoned Member
****




Posts: 137
Trouble in Paradise
10/19/19 at 13:15:23
 
Hey guys, Iím hoping for some insight and perhaps advice concerning my SE84UFO. As of late it simply stops working after a short while. I hear a slight pop or something like it and then .. no sound. This has happened a few times now, after several hours of play and after only a few minutes as well. Iíve checked all other components (including modem and router), after which, I swapped the amp out with another. The system works as expected after the swap.

The tubes were replaced 2 months ago, are all working, and seated properly. I didnít notice any odd behavior or sound prior to this either. Iím perplexed.

I havenít heard back from Steve yet so I thought Iíd ask the community. Any clues? Thank you gentlemen.
Back to top
 
 
  IP Logged
Geno
Seasoned Member
****


Without music, life
would be a mistake.
Nietzsche

Posts: 747
Re: Trouble in Paradise
Reply #1 - 10/19/19 at 15:26:18
 
Melvin, Iím sorry youíre having issues. First, make sure you have a good seating of the power cord. Mine was a little loose once and it caused it to go off and on. Then, Iíd swap out 1 tube at a time just to make sure that you donít have a faulty tube. Next, there are 3 internal fuses. It wonít hurt to just swap those out. Next would be a talk with Steve. Hope you get it figured out soon.
Back to top
 
 

SE84UFO(25th Mods)
PS Audio DSDAC JR / Cambr.Audio CXC / LRaven AudioPC / ZBIT
Technics 1210MK5(KAB Mods)-KAB/Ortof ProS 40 cart / ZP3(25th Mods)
Otari MX5050 R2R
Decware ZLC
Caintuck Alnico Betsy Baffles OR Lii Crystal 10 Baffles
(2) 12" Lii Bass Baffles
  IP Logged
Melvin
Seasoned Member
****




Posts: 137
Re: Trouble in Paradise
Reply #2 - 10/20/19 at 03:08:08
 
Thanks Geno. I reinserted the amp the same thing is occurring. I need to open it up I suppose, which is nerve-wrecking for me. I hope to speak to Steve soon as well. Fortunately, I have plenty of gear in storage to keep the music playing but I already miss my SE84UFO.
Back to top
 
 
  IP Logged
Geno
Seasoned Member
****


Without music, life
would be a mistake.
Nietzsche

Posts: 747
Re: Trouble in Paradise
Reply #3 - 10/20/19 at 21:15:33
 
Nothing to opening it up. Just a bunch of screws to take out. Iíve had to do it 4 or 5 times. Simple.
Back to top
 
 

SE84UFO(25th Mods)
PS Audio DSDAC JR / Cambr.Audio CXC / LRaven AudioPC / ZBIT
Technics 1210MK5(KAB Mods)-KAB/Ortof ProS 40 cart / ZP3(25th Mods)
Otari MX5050 R2R
Decware ZLC
Caintuck Alnico Betsy Baffles OR Lii Crystal 10 Baffles
(2) 12" Lii Bass Baffles
  IP Logged
Melvin
Seasoned Member
****




Posts: 137
Re: Trouble in Paradise
Reply #4 - 10/22/19 at 00:38:46
 
Just a follow-up .. it was the power tube(s). Paradise has been restored!

BTW, I'm such a newbie and instead of replacing the power tubes 1 at a time I replaced both, so I don't honestly know if it was 1 or both tubes. I will check at a later date.

Thanks again for your help Geno.
Back to top
 
 
  IP Logged
Geno
Seasoned Member
****


Without music, life
would be a mistake.
Nietzsche

Posts: 747
Re: Trouble in Paradise
Reply #5 - 10/22/19 at 02:32:30
 
Thatís great, Melvin. Glad youíre back in business!
Back to top
 
 

SE84UFO(25th Mods)
PS Audio DSDAC JR / Cambr.Audio CXC / LRaven AudioPC / ZBIT
Technics 1210MK5(KAB Mods)-KAB/Ortof ProS 40 cart / ZP3(25th Mods)
Otari MX5050 R2R
Decware ZLC
Caintuck Alnico Betsy Baffles OR Lii Crystal 10 Baffles
(2) 12" Lii Bass Baffles
  IP Logged
Pages: 1
Send Topic Print