Welcome, Guest. Please Login or Register
Decware Audio Forums
01/28/23 at 04:30:03 




Pages: 1
Send Topic Print
Fuse help (Read 281 times)
Bilyeaux
Seasoned Member
****




Posts: 101
Fuse help
12/02/22 at 14:51:54
 
My UFO 2.1 is just over 1 year old. I had a fuse blow with original rectifier tub about 3 months in. Changed it and all good until this week. Up at about 4:30 am an flipped on switch and nothing. Assumed a different fuse this time as no power or lites at all. Found fuse under power receptacle blacked and replaced. Hooked back up and still nothing. Opened amp and inspected the two clear glass fuses 250V and appear fine. Was pulling out the third fuse (over the two yellow wires) and broke this fuse……It is a 5tt 6A 125V.

Two questions; do I match this fuse exactly or are alternates available?

If this tube was good what would cause amp to not power on? I ensured power plug hot and tight and inserted my backup PS300 amp and all good?

Thanks for any assistance, Randall
Back to top
 
 

PS Audio GCD & UFO2 & S300, P300 Regen, Rega P6 w/ NEO and Rega MM Phono, Marantz CD6006, Bluesound Node 2i, Nakamitchi Cassette, Syzygy Sub, Omega JR XRS Towers & 74' Heresy rebuilt from Crites, Underwood Cables/Cords, AQ connects
  IP Logged
CAJames
Seasoned Member
****


"I've run every
red light on memory
lane."

Posts: 839
Re: Fuse help
Reply #1 - 12/02/22 at 15:18:47
 
Quote:
Posted by: Bilyeaux      Posted on: Today at 14:51:54


...do I match this fuse exactly or are alternates available?


Not sure what kind of alternate you are thinking of. I would stick to the same value.


Quote:
If this tube was good what would cause amp to not power on?


Did you check the mains fuse to be sure it didn't blow again? and/or try another fuse just in case the new one is bad. If a fuse blows it is "usually" the rectifier and a good plan it to replace the fuse then power up the amp without the rectifier tube and confirm the tubes light up. If they do then add a new rectifier and you should be good to go. If they don't then you've got a more serious problem and my suggestion is to talk to Steve.
Back to top
 
 

[FOOBAR2000 | Jay's CDT2 MRK3] -> Denafrips Terminator 2 + Gaia
Sumiko Pearwood -> Mapleknoll Athena -> Luxman SUT -> Maple-tree Phono 3E
Woo WA22 -> Space-tech 300B , 2x UFO25s on order
Omega SAM , Hifiman Arya, Senn HD-650
  IP Logged
Bilyeaux
Seasoned Member
****




Posts: 101
Re: Fuse help
Reply #2 - 12/02/22 at 23:07:40
 
Thanks James Ill giver er a shot!
Back to top
 
 

PS Audio GCD & UFO2 & S300, P300 Regen, Rega P6 w/ NEO and Rega MM Phono, Marantz CD6006, Bluesound Node 2i, Nakamitchi Cassette, Syzygy Sub, Omega JR XRS Towers & 74' Heresy rebuilt from Crites, Underwood Cables/Cords, AQ connects
  IP Logged
Bilyeaux
Seasoned Member
****




Posts: 101
Re: Fuse help
Reply #3 - 12/03/22 at 17:38:04
 
James, replaced that fuse, removed the Rectifier (didn’t know you could do that),  and all powered up. Off, then rectifier back in and playing some awesome blues. Rolled one of my 80 globes in and fantastic. A previous one had a little noise but this one is dead quiet. Thanks Man for the assist!
Back to top
 
 

PS Audio GCD & UFO2 & S300, P300 Regen, Rega P6 w/ NEO and Rega MM Phono, Marantz CD6006, Bluesound Node 2i, Nakamitchi Cassette, Syzygy Sub, Omega JR XRS Towers & 74' Heresy rebuilt from Crites, Underwood Cables/Cords, AQ connects
  IP Logged
Lon
Seasoned Member
****


"Love without
guts is
worthless!"
Philip K. Dick

Posts: 20682
Re: Fuse help
Reply #4 - 12/03/22 at 18:26:23
 
Back in action! Fantastic!
Back to top
 
 

HR-1,ZTPRE,ZBIT,ZROCK2,SE84UFO3-25th x2, CSP3-25th.Taboo Mk IV;Rega RP3 all GrooveTracer mods;PSAudio:PST+DSD,P15,NPC,PowerBases,AC-12 pwr cbls,Reference spkrcbls; Mapleshade SamsonV3;VooDoo:Cremona+Amati interconnects, IsoPods; headphones:Sennheiser HD800S,ZMF Or
  IP Logged
Pages: 1
Send Topic Print