Welcome, Guest. Please Login or Register
Decware Audio Forums
07/30/14 at 20:30:06


Pages: 1
Send Topic Print
original imperial impedance anomaly? (Read 130 times)
arficus
Verified Member
**




Posts: 3
original imperial impedance anomaly?
06/13/14 at 05:15:09
 
I have some original imperial corner horns. Judging by the DC resistance in one speaker (haven't checked the other yet), the P15LL is 8 ohms and the RP302 is 16 ohms (haven't checked the mid horn yet). Is/was this ever normal? Hoping that perhaps the xover compensates somehow? If I simply have mismatched drivers, which output taps would you recommend I connect to on my ST70?
Thanks,
Ethan
Back to top
 
 
  IP Logged
DirtDawg
Seasoned Member
****




Posts: 159
Re: original imperial impedance anomaly?
Reply #1 - 07/12/14 at 01:33:52
 
I am not that familiar with your exact set up, but I can tell you manufacturers mix 8 ohm and 16 ohm and other impedances all through out history with no ill effects.

Yes, the crossover is designed to take this into account. No problem.

Before you do anything, check to make sure that all you drivers are working properly. If both low drivers match, both high and mid drivers match in pairs, then all should be fine.

BTW, matching drivers could easily be ten to fifteen percent off from each other in impedance and still work fine as a stereo pair.

If I was going to look for something to TWEAK your vintage speaker systems a bit, I might think of upgrading the actual crossover components with modern higher quality components, using similar value parts, to start with.
Back to top
 
 
WWW DirtDawg DirtDawg NO! NO!   IP Logged
Pages: 1
Send Topic Print