Welcome, Guest. Please Login or Register
Decware Audio Forums
09/02/14 at 12:54:22


Pages: 1
Send Topic Print
Running SE84C+ as monos (Read 887 times)
KobeeDog
Senior Member
***




Posts: 64
Running SE84C+ as monos
08/20/13 at 23:06:08
 
Have another amp coming to add to add to my collection. I would like to run my 2 SE84c+ as mono blocks.

I understand how to bridge them,  but which RCA in do I use in mono mode?
Back to top
 
« Last Edit: 08/20/13 at 23:29:02 by KobeeDog »  
  IP Logged
SteveC
Seasoned Member
****




Posts: 108
Re: Running SE84C+ as monos
Reply #1 - 08/20/13 at 23:25:06
 
both with a Y.    I remember doing this in the past.  

EDIT: Both L and R of one set of inputs.  Use the input selector switch to choose which pair.

http://www.decware.com/newsite/SE84CPLUS%20Owners%20Manual.pdf


"To bridge the amp into mono you simply series the output jacks. To do this, take a piece
of wire and connect the left positive speaker jack to the right negative speaker jack. The
two remaining jacks will be used to power the speaker.
Also, it is important to feed a signal into both the left and right input jacks
simultaneously. This can easily be done with a Y-Adapter cable with two male RCA jacks
on one end and a single female RCA jack on the other."

I don't remember if the sound got quieter when unplugging one side or the other.
Back to top
 
« Last Edit: 08/20/13 at 23:28:38 by SteveC »  
  IP Logged
KobeeDog
Senior Member
***




Posts: 64
Re: Running SE84C+ as monos
Reply #2 - 08/20/13 at 23:27:26
 
Thanks Steve. It's funny, but my manual doesn't say anything about that in section about bridging.
Back to top
 
 
  IP Logged
KobeeDog
Senior Member
***




Posts: 64
Re: Running SE84C+ as monos
Reply #3 - 08/21/13 at 00:24:46
 
Looks like I got an outdated manual with my Zen.
Back to top
 
 
  IP Logged
Pages: 1
Send Topic Print