Welcome, Guest. Please Login or Register
Decware Audio Forums
08/20/14 at 07:58:11


Pages: 1
Send Topic Print
bad bias switch on se84cs (Read 382 times)
trench
Verified Member
**




Posts: 7
bad bias switch on se84cs
01/16/13 at 00:46:25
 
I was wondering how I could get a new bias switch for my se84cs.
It seems to be a little dirty I have tried cleaning it but I keep getting some fuzzy noise every once and a while and just now I wanted to change the setting to the front position and noticed less output on one of  my speakers.

I can solder and fix it myself.


Back to top
 
« Last Edit: 01/16/13 at 23:49:54 by trench »  

Decware SE84CS,PS Audio 4.6/m500,Audio Nirvana supercast 10/mkII 2.8, Nad 515bee
  IP Logged
Steve Deckert
Administrator
*****


If the 1st watt
sucks why continue?

Posts: 2379
Re: bad bias switch on se84cs
Reply #1 - 01/16/13 at 03:20:37
 
Back to top
 
 
WWW   IP Logged
trench
Verified Member
**




Posts: 7
Re: bad bias switch on se84cs
Reply #2 - 01/16/13 at 23:44:34
 
Thank you Steve, I have always had it in the front position and wanted to give it a good listen in the front position. Even with my left channel a little lower the imaging and soundstage were better than I ever heard, I could get a sense of the holographic imaging you talk about ,made me smile.

If I sent it in to get the cce mod would you test it to make sure it's to your specs?
Back to top
 
« Last Edit: 01/16/13 at 23:51:36 by trench »  

Decware SE84CS,PS Audio 4.6/m500,Audio Nirvana supercast 10/mkII 2.8, Nad 515bee
  IP Logged
Pages: 1
Send Topic Print