Welcome, Guest. Please Login or Register
Decware Audio Forums
07/30/14 at 20:15:00


Pages: 1
Send Topic Print
fuses (Read 1699 times)
don pettit
Senior Member
***




Posts: 78
fuses
02/01/11 at 18:55:45
 
recently sold my zen in order to finance a new taboo.  problem:  buyer returned amp complaining that fuses kept blowing.  i seem to remember that fuses from 4-6 amps were suitable for the zen but i cannot find that info here and i did not receive a manual when the amp arrived.   anybody know?  thanks,  don pettit
Back to top
 
 
  IP Logged
don pettit
Senior Member
***




Posts: 78
Re: fuses
Reply #1 - 02/01/11 at 19:10:06
 
does any body know the appropriate fuse strength for the zen 84c+?  i have no manual and just cannot find out.  i think i read at one time the answer was from 4-6 amps.  true/false?  thanks, don pettit
Back to top
 
 
  IP Logged
MarkBlair
Senior Member
***




Posts: 59
Re: fuses
Reply #2 - 02/01/11 at 19:53:02
 
Don -

The PDF manual for the SE84C+ says it's a 3 amp fuse...

Mark
Back to top
 
 
  IP Logged
don pettit
Senior Member
***




Posts: 78
Re: fuses
Reply #3 - 02/01/11 at 19:57:02
 
thank you mark,  don pettit
Back to top
 
 
  IP Logged
MarkBlair
Senior Member
***




Posts: 59
Re: fuses
Reply #4 - 02/01/11 at 20:41:47
 
By the way -- the manual mentions that if the rectifier tube blows, the tube will blow, too.  So, I wonder if it would be worth swapping rectifier tubes for troubleshooting purposes (if not already tried)...

Mark
Back to top
 
 
  IP Logged
MarkBlair
Senior Member
***




Posts: 59
Re: fuses
Reply #5 - 02/01/11 at 20:43:29
 
Oops -- I meant to say the FUSE will blow, too!
Back to top
 
 
  IP Logged
don pettit
Senior Member
***




Posts: 78
Re: fuses
Reply #6 - 02/01/11 at 21:01:21
 
the amp is still on the way back from hawaii.  i had the same thought as i had a rectifier tube act up and a fuse go about the same time and that was the first move i was intending to try.  i will do that and let you know.  thank you for your interest, mark.  don
Back to top
 
 
  IP Logged
Rivieraranch
Seasoned Member
****




Posts: 1272
Re: fuses
Reply #7 - 02/01/11 at 22:49:42
 
Make sure the fuses are fast blow.  It sounds like a crap excuse to return the amp. If I were you I would swap rectifiers and fuses. I am sure nothing is wrong with the amp. You might want to sell it over at Audiogon with a nice photo and all.
Back to top
 
 

DECWARE CSP2+, TABOO MK III; SE84CKC; HR1; TRAPEZIUM DESKTOP SPEAKERS; TECHNICS SL1200MK5 turntable; Ah! Njoe Tjoeb CD player; MARANTZ 2226B, 2216B receivers; SENNHEISER HD-580 headphones
  IP Logged
don pettit
Senior Member
***




Posts: 78
Re: fuses
Reply #8 - 02/01/11 at 23:15:45
 
agree, agree.  however,  the buyer is a fine person,  just not familiar with tube audio and i was not much help being one thousand miles distant.  i had sent two rectifier tubes and failed to ask if he had tried both of them.  my bad.  however,  the upside is that i am gonna end up with a taboo. yippee!   so, the zen is still available if healthy and i should know that by this time tomorrow. thanks for your input.  don
Back to top
 
 
  IP Logged
don pettit
Senior Member
***




Posts: 78
Re: fuses
Reply #9 - 02/03/11 at 00:30:12
 
hello all,  amp is back, hooked up and running fine.  problem was rectifier tube(should never have sent it with sale).  my dumb.  will be on audiogon again soon to help defray cost of new taboo which is under construction.  all good and thanks for the help,  don pettit, long beach, washington
Back to top
 
 
  IP Logged
Pages: 1
Send Topic Print