Forums
http://www.decware.com/cgi-bin/yabb22/YaBB.pl
AUDIO FORUMS >> General Discussion and Support >> Gain Problem Using Phono - Need SUT?
http://www.decware.com/cgi-bin/yabb22/YaBB.pl?num=1314893053

Message started by dwolek on 09/01/11 at 17:04:12

Title: Gain Problem Using Phono - Need SUT?
Post by dwolek on 09/01/11 at 17:04:12

My set up is as follows - Project Debut 3 TT, Ortofon OM10 MM cart, Cambridge Audio 540P phono, SE34I.2, HDT's.  Had a Project PhonoBox SE with a bunch of DIP switches and after fiddling, found the correct combo to give me great gain and extension (the recomended MM setting did not yield the enough volume) This phono amp died and I replaced it with a MM only phono and damn, not enough gain, pretty weak sonics etc.  After some research, it would seem that I need a Step Up Transformer (SUT) to get more gain and better extension, even though these are typically used with MC carts.  

My question to the Decware community is what phono gear are you using to get the necessary gain out of your amp and are you using SUT's.  I'm having a bit of frustration since going whole hog into Decware gear, but since I'm committed to it now, I need to make it work for my ears.  BTW, I don't listen at ear bleeding levels, far from it, even at nearfield listening , something is missing.

Thanks

Title: Re: Gain Problem Using Phono - Need SUT?
Post by Rivieraranch on 09/01/11 at 21:34:57

The only thing missing is a DECWARE phono preamp.

Forums » Powered by YaBB 2.2.2!
YaBB © 2000-2008. All Rights Reserved.